Follow

Linux - Why am I getting "libEGL warning: DRI2: failed to authenticate"?

This warning indicates that the Direct Rendering Infrastructure (DRI) is not available or accessible on your platform. The root cause of this can be

- OpenGLES is not installed

- graphic drivers do not support it or they are not correctly installed.

 

DRI reduces the overhead to send commands to the graphics hardware but it is not required to run Scandit SDK. The SDK itself provides a fallback method.

 

In case you're experiencing a lower or unexpected performance on Linux and the above warning is triggered, please reach out to us and we can verify the details on an individual basis as it's related to your environment and setup.

You can contact us via:

https://support.scandit.com/hc/en-us/requests/new

 

 

Was this article helpful?
3 out of 9 found this helpful
Have more questions? Submit a request